itunesconnect error

Since my iphone OS got upgraded to iOS 4, I had to upgrade my Xcode as well… I just installed the latest Xcode 3.2.3 from xcode_3.2.3_and_iphone_sdk_4__final. It took out my previous SDK versions, and now I only have 3.2 and 4.0 left.

It took me a while to fix all the framework paths. For your convenience, right click on a red framework, then choose General, for Path Type choose Absolute Path, then navigate to the following path to re-select your framework paths.
/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS3.2.sdk/System/Library/

Then when I got to the itunesconnect submission page, I got the following error message:

The binary you uploaded was invalid. An application targeting the iPhone device family may not require a iPhone OS Deployment Target of 3.2, which is an iPad-only OS.

Very puzzling as always… After trying things here and there, I settled by changing the Base SDK to iPhone Device 4.0. This may not be a good choice if you want to support old iphones, but it’s one way to submit an app update…

Hope this could save you some time on that error message.

One thought on “itunesconnect error

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s